
﻿

1

Guide
for 

Flynax Software SEO Setup

© Flynax, 2007-2022



﻿

2

Table of Contents
|| About the Guide

|| 1.1. The Under Construction plugin

|| Setting up pages

|| 2.1. Setting up metadata for pages
|| 2.2. Configuring page URLs
|| 2.3. Developer Settings
|| 2.4. Enabling links to pages in the menu

|| Publishing news

|| 3.1. Publishing news
|| 3.2. News global settings

|| Setting up metadata and URLs for categories

|| 4.1. Setting up metadata for categories
|| 4.2. Category link appearance
|| 4.3. URL category ending

|| Adding metadata and listing URLs

|| 5.1. Adding category metadata
|| 5.2. Listing URLs

|| Configuring metadata and URLs of seller pages

|| 6.1. Configuring metadata for seller pages
|| 6.2. Seller page URLs

|| SEO options

|| 7.1. Basic settings > Common > Canonical tag
|| 7.2. Basic settings > Pictures > Output image format

|| Multifield/Location Filter plugin

|| 8.1. Location Filter
|| 8.2. URLs and their structure on geofiltered pages
|| 8.3. Listing location in URLs
|| 8.4. Multilingual location paths
|| 8.5. Locations in seller page URLs
|| 8.6. Adding geomodified URLs to the sitemap
|| 8.7. Location variables in metadata

|| Field-Bound Boxes plugin

|| 9.1. Setting up pages
|| 9.2. Common metadata patterns



﻿

3

|| 9.3. Unique metadata and URL for every element

|| Filters plugin

|| 10.1. X-Robots-Tag: noindex, nofollow

|| 10.2. Adding filtering field name to metadata

|| Enabling sitemap.xml



Flynax Software SEO Setup

4

ÌÌ Flynax Software SEO Setup

We are glad to present you with the Flynax SEO Feature Guide. Before getting to the point we'd like 
to clary the purpose of the Guide. The Guide has nothing to do with the selection of search keywords, 
processing analytical data, copywriting, or search engine optimization. The purpose of the Guide is to 
describe features and functions associated with the SEO tools of the script and how to set them up. 
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1. The Under Construction plugin
It is very likely that you will put your site to production without any listings or with a minimum number 
of listings. Populating the site with listings will take time and effort. At the same time, there is no 
guarantee that your site will not be indexed by search engines before you decided to submit it, which 
may cause your site to be indexed while it is being set up. Offering your users a site that is not fully 
ready to run is not a good scenario, which is why we recommend installing the Under Construction 
plugin right after deploying the script so you could take as long as you need to set up your site. You 
will be able to disable the Plugin once you're done with setting up and populating your site with data. 

We strongly recommend against installing and enabling the Google and Yandex Sitemap plugin and 
adding the sitemap.xml to the webmaster's console until your site is ready to be submitted to search 
engines. 
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2. Setting up pages
2.1. Setting up metadata for pages

The home page is a top priority page because search engines always start with indexing the home 
page. For this reason, start to optimize the site with the home page. First, you will need to fill in the 
metadata for the home page. Go to the Admin Panel > Content > Pages > Select a page and click the 
Edit icon (a pencil on the screenshot below).   

 

On the Edit page, the most important fields are the H1 tag, title, and meta description.

 

Make sure you've filled in the fields in all the languages available on your site. 

NOTE: We didn't mention the meta keyword field because a few years ago Google stopped using the 
keywords meta tags in raking sites. Therefore, there is no use in wasting your time filling in the field. 
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Once your home page gets indexed by search engines it will look like on the screenshot below.

 

In a similar way, you will need to enter metadata for all the pages.  

If you don't have enough time and resources initially for selecting and filling in metadata you may 
enable logging in for such pages so that only logged-in users could access the pages. That will prevent 
search crawlers from indexing pages that you haven't yet equipped with the necessary metadata and 
will give you enough time for doing so. 

2.2. Configuring page URLs

The URLs of pages should reflect the content offered on the pages. So you will need to edit the URLs 
of all the pages. Go to the Admin panel > Content > Pages >  Page Manager, then using the pagination 
at the bottom of the page find a needed page, and click the Edit icon. After opening the Edit page find 
the Page URL field and edit its URL.
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Flynax allows you to add multilingual URLs of pages if you use two and more languages on your 
site. To enable the multilingual URLs, proceed to the Admin Panel > Basic Settings > Common > 
Multilingual paths. 

You also may enable URL Transliteration, which will allow you to generate URLs of the categories and 
pages in different languages, for example. 

Enabling the feature makes sense if you offer two or more languages on your site. 

 

2.3. Developer Settings

You could have noticed two fields - page type and page controller when editing a page. The settings 
are intended for developers, which is why we recommend against managing them if you don't quite 
understand their designation.
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2.4. Enabling links to pages in the menu

Every important page should be presented in the main menu or in the footer menu. To enable a page 
link in the menu, proceed to the Admin Panel > Content > Page Manager > Select a page from the list 
and click the Edit icon. On the Edit page find an option - Show page link in (see point 2 on the screen-
shot) and select the menu, to which you want to add the link. 

 

Don't forget to add the important pages to the sitemap.xml file. Select Enable and click the Edit 
button.

IMPORTANT: We've already mentioned the sitemap.xml at the beginning of the Guide; the file is 
generated with the Google and Yandex sitemap plugin. Make sure that at this stage the Plugin is disa-
bled as you're setting up your site and there is no access to site pages. We'll get back to the Plugin at 
the end of the Guide. Make sure the nofollow attribute (option 1 on the screenshot) is enabled because 
it prevents search bots from crawling pages. 
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3. Publishing news
3.1. Publishing news

Publishing news on the site on a regular basis contributes to better site indexing and ranking in the 
relevant area. To add news go to the Admin Panel > Content > News. Fill in the necessary field (except 
for the keyword tag field) and click the Add News button. Try to publish news regularly.

3.2. News global settings

 

You will be able to manage the global settings for news in the box from the Admin Panel > Basic 
settings > News tab. From the manager you will be able to set a number of news posts in the box, a 
number of characters in the excerpt, and the length of a news post.   
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4. Setting up metadata and URLs for categories
4.1. Setting up metadata for categories

Adding metadata to categories is another important SEO task that you will need to handle along with 
filling metadata for site pages. For this reason, you will need to populate the most important catego-
ries and also all the first-level categories with metadata. To add metadata, proceed to the Admin 
Panel > Categories  > Select a category (you may search for it if you have too many of them) > Click the 
Edit icon in order to open the category settings.

 

All the fields on the screenshot are important for SEO and need to be filled in accordance with the 
SEO standards and relevant content of the category.  

You may edit a category in a different way, which might turn out to be more convenient for you. Go to 
the Admin Panel > Categories > Browse and select a needed category from the list. Then click the Edit 
icon to open the page with settings. 
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4.2. Category link appearance

All the categories are grouped by listing types. Therefore, you may find URL settings for categories 
in the corresponding listing type settings. Go to the Admin Panel > Listings > Listing types > Select 
a listing type and click the Edit icon. After opening the Edit page go to the Listing Type URL option.

The following options are available: 

Full URL

When a domain is followed by the listing type and category one after another in the URL.  

www.domain.com/motors/cars/bmw.html 
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where /motors is a listing type path

/cars/bmw.html is a category path

Short URL

When a listing type is left out in the URL and only categories are shown.

www.domain.com/cars/bmw.html 

On subdomain

When a listing type is put to a subdomain and the domain is followed by a category. 

motors.domain.com/cars/bmw.html 

4.3. URL category ending

The category URLs may end in .html and slash /, for instance.

www.domain.com/motors/cars/bmw.html 

www.domain.com/motors/cars/bmw/ 

To disable .html for a listing type go to the Admin Panel > Listing types > Select a listing type > Click 
Edit. Find Enable .html at the end of URLs and click Disable and Save changes. 
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5. Adding metadata and listing URLs
5.1. Adding category metadata

Adding metadata to listings is also an important SEO practice. Despite the fact that listings and their 
pages are created by users, you cannot make them fill in the metadata for every listing but you can 
build a pattern using variables that will be replaced with corresponding field values in the front end. 
That will give you an acceptable result in the long run and will allow search engines to index listing 
pages. 

You may set up metadata patterns for listings from the category settings. If you're dealing with similar 
listings then you will need to add a metadata pattern only for the primary or parent category while the 
other categories and subcategories will inherit the settings. To edit a category and pattern settings, 
proceed to the Admin Panel > Categories > Select a category > Click the Edit icon. To give you an 
example let's edit the Auto category. After scrolling down a bit, you will see 3 fields.

- Title

- Meta keywords

- Meta description

As we mentioned above, there is no need to fill in the keyword tag field, but you may fill in it if you 
think it makes sense. 

When adding metadata you may mix variables with your own text to make resultant titles and meta 
description sound natural. You also can move variables in the field. To add a variable, select a needed 
variable from the dropdown that you may find under the field and click Add. That will add a key of the 
selected variable (all the added variables are embraced in the figure brackets - {}). When generating a 
listing page, the script will replace the variables with field values. The resultant listing titles and meta 
description will look like on the screenshot below.  
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5.2. Listing URLs

Listing URLs are made up of category URLs, listing title converted into an URL and listing identifica-
tion numbers (for configuring category URLs check 4.1 and 4.2). You may set up the listing title from 
the form builder section in the category settings from the Admin Panel > Browse > Select a category 
> Click the Build Listing Title Form button. 

  

You will be taken to the page where you will be able to select the fields that will be used for gener-
ating listing titles and in listing URLs accordingly. 
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6. Configuring metadata and URLs of seller pages
6.1. Configuring metadata for seller pages

To configure metadata for user account pages - sellers we use patterns with field variables similar to 
listings (5.1). For creating metadata patterns for the account type go to the Admin Panel > Account 
type manager > Click Edit.  

 

You will be taken to the account type Edit page. Scroll down to the following fields: 

- Account type title, 

- Account type H1 tag, and 

- Account meta description.

 

You may use variables in all the fields mentioned above. Variables will be replaced with corresponding 
values from the user account form. Actually, you may set up metadata patterns for user accounts 
similar to those for listings. 
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In the front end, it will look like this.

Metadata in the code of the page will look like this.

6.2. Seller page URLs

As the Administrator you have may give your users the ability to create individual pages with their 
names in URLs from the settings of an account type. To allow sellers to have their own pages you will 
need to enable Generate individual pages for users of this type from Admin panel > User accounts > 
Account types > Select an account type > Click Edit.  

 

You also can enable Build URLs of individual pages on subdomains in order to move the seller 
addresses to subdomains. 

IMPORTANT: You may enable subdomains for seller URLs if the wildcard subdomain option is enabled 
on your server and the option is enabled from the Admin Panel > Basic settings > User accounts > 
Wildcard subdomains. 



Flynax Software SEO Setup

18

With the subdomain and Build URLs of individual pages on subdomain options enabled, the seller 
URLs will look like this.

braman.domain.com

With the subdomain option disabled, the URL will have the following structure.

www.domain.com/braman/ 

With the Build URLs of individual pages on subdomain option disabled, the page URL will look like 
this. 

www.domain.com/sellers/braman/ 
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7. SEO options
7.1. Basic settings > Common > Canonical tag

We recommend enabling Canonical tag because using the canonical tag allows you to avoid duplicates 
due to variants of links to a page.  

7.2. Basic settings > Pictures > Output image format

We recommend using the WEBP format for storing listing images on the server. WEBP is a format that 
allows you to reduce the size of files up to 40%, which contributes to higher load speed on the user 
side. Using the format allows you to better LCP and CLS metric in Google Speed Insights. We also 
recommend against setting the Image quality higher than 70.
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8. Multifield/Location Filter plugin
8.1. Location Filter

The Location Filter plugin has a significant impact on SEO, which is why configuring its SEO functions 
is of high priority. If you want to filter listings on a page by location then you will need to enable the 
option from the Admin Panel > Basic Settings > Geo Filter > Scroll down to Filtering Listings/Accounts 
on Pages. You will find all the pages for which geo-filtering is available. Enable the filtering option to 
required pages. If you want to add locations to page URLs then you will need to enable the Add loca-
tions to listing URLs setting. 

 

8.2. URLs and their structure on geofiltered pages 

With the Add locations to listing URLs option enabled (that we've activated in the previous step), a 
page URL might have a different structure, which depends on two settings that you may find on the 
same page of the Plugin settings but in the section called SEO. They are Location on subdomains and 
Location structure in URLs.

 

The Location on subdomains option allows you to enable locations on subdomains. You will need to 
make sure that wildcard subdomains are enabled on your server. With the subdomains enabled and 
switching from Location structure in URLs to Mixed, the page URL will have the following structure. 

usa.domain.com/florida/miami/

When set to Full, will have the following URL.

usa-florida-miami.domain.com

When set to City only, will have the following URL.



Flynax Software SEO Setup

21

miami.domain.com

With the subdomains disabled and in the Full mode, the URL will have the following structure. 

www.domain.com/usa/florida/miami/

In the City only mode, the URL will have the following structure. 

www.domain.com/miami/

The Mixed mode is available only with subdomains enabled.

8.3. Listing location in URLs

To add locations to listing URLs you will need to enable the Add locations to listing URLs option that 
you may find in the SEO section from the basic settings of the Plugin. The listing URL will be gener-
ated with the values described in 8.2 and will have the following structure.

miami.domain.com/motors/cars/hyundai/i30/2015-huyndai-i30-67781.html

8.4. Multilingual location paths

If you want to add location paths in URLs in different languages, then you will need to enable the 
Multilingual paths setting. In order to show location paths in different languages you will need to 
proceed to the Admin Panel > Plugins > Multifield/Location Filter > Find an entry with locations and 
click Edit > Find a location in the manager and edit its path.

 

8.5. Locations in seller page URLs

You also can add locations to URLs of seller pages. In order to do it you will need to check the box for 
Add location to URL after enabling filtering for Sellers/Agents. You will need to select the URL option 
from the Filtering ads on seller page dropdown to make it work. The page URL will have the following 
structure (when generating seller page URLs, the options described in section 6.2 will be taken into 
account). 

miami.domain.com/braman/ 
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It also should be noted that you cannot enable locations on subdomains and seller addresses on 
subdomains concurrently (section 6.2). You will need to select what is more appropriate for running 
on subdomains. 

8.6. Adding geomodified URLs to the sitemap

When filtering listings by locations the Plugin returns filtering values in URLs.The option allows you 
to add URLs of such geomodified pages to the sitemap.xml file (Google and Yahoo Sitemap plugin is 
supposed to be installed). 

IMPORTANT: You should take into account that the number of geomodified and with the Add location 
to URL option enabled generates thousands of URLs. For instance, the world location database (default 
setup) includes 167,000 locations. Consequently, the number of URLs/copies of a page amounts to 
167,000. If you enable Multilingual paths and translate locations to other languages then multiply the 
number on the number of languages. 

You will get large numbers in the long run. You should realize the math and be sure that your server 
has enough resources for parsing that number of URLs and for generating sitemap.xml files. It is for 
this reason that the Add location to URL option has two modes. 

All URLs - a high load mode that allows you to add all the locations to the sitemap.

URLs with listings/accounts only - a light and recommended mode that allows you to add only those 
pages that contain listings and accounts. 

8.7. Location variables in metadata

The plugin allows you to use variables in metadata (H1 tag, title, meta description) and in the descrip-
tion of all pages and category pages, to which geofiltering was applied. To show location, say in a page 
title you will need to add a location variable to the title of that page, for instance, let's take a look at 
the home page. 

- Open Admin panel > Pages > Find the Home page > Click the Edit icon

- Use the following variables in the title field. 

Buy new or used cars {if location} in {location}{/if}

The {location} variable will be replaced with the corresponding location values, separated with the 
comma starting from the last level. In our case from city. By filtering listings by San Francisco we'll 
get the following title. 

Buy new or used cars in San Francisco, California, USA

The title without the location data will have the following structure. 

Buy new or used cars

- You have the ability to manage certain locations and use variables connected to a certain location 
level: 

{location_level1} – First location level; by default, it is a country name.

{location_level2} – Second location level; by default, it is a region/state name.

{location_level3} – Third location level; by default, it is a city name.

For instance,
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Buy new or used cars{if location_level3} in {location_level3}, {location_level2}{/if}

In this case, if a city is available then the title will have the following structure.

Buy new or used cars in San Francisco, California

- You also may combine location variables with other variables. You will learn more about how to do 
it in section 9.2. Below you may find an example of using location variables along with others in the 
title. 

{item} body style vehicles for sale {if location_level3} in {location_level3}, {location_level2}{/if}

On the Browse cars by Sedan body style page and filtered by San Francisco, we'll get the following 
title. 

Sedan body style vehicles for sale in San Francisco, California
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9. Field-Bound Boxes plugin
9.1. Setting up pages

Another plugin that allows you to generate pages useful for indexing is Field-Bound Boxes, where 
every content box contains links to generated pages. The Plugin offers a number of useful settings 
that will contribute to better SEO. Let's start with creating a new box. 

Let's take a look at the body styles in the Auto classified script. Proceed to the Admin Panel > Plugins 
> Field-Bound Boxes > Click Add a box or the Edit icon if you want to edit an existing box. Then go to 
the Page settings on the Add/Edit box page.

On the Add a Box/Edit page scroll down to the Pages settings section. 

The first setting Box Landing Page creates a parent page, the page to which a user will be able to go 
back from the child page via the breadcrumbs.  

You also may set up the URL and add metadata to the parent page from the Page Settings. 
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9.2. Common metadata patterns

If you added too many elements to the box, for example, boat brands or popular cities (such boxes may 
contain more than 30 elements) filling in metadata for all the pages will take you too much time. In 
this case, you may use the general pattern for generating metadata for the elements of the box. Open 
the Add/Edit page then scroll down to Items SEO defaults. 

 

You may use your own text and the variable {item} in all the metadata fields and description fields 
that will be replaced with the element name (in our case with the name of the body style) and in our 
example, on the Sedan page, we'll get the following metadata. 
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The metadata in the code will look like this.

9.3. Unique metadata and URL for every element

If you want to add a unique text to metadata or description of an element page (body style in our case) 
you will need to go back to the list of content boxes, select a box and click the Edit icon. 

 

Select an element from the element manager and click the Edit icon.
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You may set a page path, page description, and enter metadata on the element Edit page. All the 
options come one after another.
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The data in the general pattern will be replaced with unique data for the Sedan page. 
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10. Filters Plugin
10.1. X-Robots-Tag: noindex, nofollow

On the filtering results page by field you may enable the «X-Robots-Tag: noindex, nofollow» tag. This 
will allow you to prevent the pages, content on which was filtered by fields, from being indexed. 

In order to enable the tag for the field proceed to the Admin Panel > Plugins > Select a filter box and 
click the Build icon (create it if you haven't yet created it). 

 

Then select a needed field and click the Gear icon in order to manage the settings.
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On the Settings page, select the Prevent bots from crawling option and enable it. 

10.2. Adding filtering field name to metadata

As you can see on the previous screenshot you also may apply the field names and their values, when 
filtering by fields, to H1 tag, title, and meta description of a particular page. This will allow you to 
generate unique metadata for the page and will prevent duplicate content in the SERPs. After filtering 
the content you will get the following metadata. 
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11. Enabling sitemap.xml
Once you're done with all the settings, fine-tuned the site to your requirements, and created the 
patterns for generating metadata, you may put your site online by disabling the Under Construction 
page (See section 1.0 above). 

You will also need to install the Google and Yahoo Sitemaps plugin and add the URL of the sitemap 
file to your Google Webmasters account or to the corresponding manager of another search system. 

The sitemap.xml file address will have the following path. 

https://www.domain.com/sitemap.xml


