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Creating and setting up Facebook App

» Creating and setting up Facebook App

Setting up the Auto Poster Plugin is conducted in three steps:

1. Creation and basic setup of Facebook App.

2. Setting up the Auto Poster plugin and connecting it to the newly-created Facebook App.

3. Submitting Facebook App for approval to Facebook.

o Creation and basic setup of Facebook app

To create and configure the Facebook Auto Poster plugin, you will need to complete several steps
outlined below:

1. Go to My Apps - https://developers.facebook.com/apps/ and click the Create App button. You will
see a pop-up with three options.

Pic1

Create an App ID

How are you using your app? Learn More

Manage Business Integrations

Create or manage Pages, Groups, Events, Ads, Messenger, Instagram or
other types of business integrations.

Integrate a Third-Party Gaming App

Create an app to let people play mobile games that are off the Facebook
platform. Note: Select For Everything Else option to build Instant Games or
Canvas Games.

For Everything Else
Select if you're imtegrating Facebook | ogin, building an Instant Game or app
that will access user data on Facehook or Instagram
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2. Click Manage Business Integrations. Another pop-up will show up. You will need to enter your App
name, email address that will be used by Facebook to contact you, purpose of the App. Select Yourself
or your own business as the principle purpose.

Pic 2

Create an App ID

App Display Name
This is the app name associated with your app 1D.

Autoposter

App Contact Email
This email address is used to contact you about potential policy violations, app restrictions or steps to recover the
app if it's been deleted or compromised.

some(@mail.com

App Purpose
This app’s primary purpose is to access and use data trom Facebook’s Plattorm on behalf of:

@ Yourself or your own business
Clients @

If you are developing an app that accesses and uses data from Facebook's Platform on behalf of
clients, you are subject to Section 5h of the Platform lerms

Do you have a Business Manager account? - Optional
Your app may need to be connected to a verified Business Manager account 1o access difterent levels of data. It you
do not have a Business Manager account, you can create one later in the process.

No Business Manager Account selected - l

By proceeding, you agree to the Facebook Platform Terms and Developer Policies

Cancel Create App ID

After entering the name for the App and contact email, you will be taken to the main page of your
App, where you'll be able to integrate a Facebook Login scenario. To get started, select this option
and click the Set up button.

Pic 3

Add Products to Your App

Woe've streamlined the app creation process by surfacing the products and permissions needed to build the app type you selected.

© o &

Analytics Audience Network Facebook Login

Linderstand how penple engage with your
DUSINESS ACrOSS apPs, devices, plattarms and
wabsites.

Maongtize your app and grow revenie with ads

e Fasdanaak MR The world’s number one social login product.

Read Docs SetUp Read Docs SetUp Read Docs SetUp

® (&
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3. You will need to configure the Facebook Login module. For this, go to the Dashboard > Facebook
Login > Settings.

Pic 4

n Easily add Facebook Login to your app with our Quickstart

Client OAuth Settings

Yes

Client OAuth Login

. Web OAuth Login Enforce HTTPS
2 Enables web-based Client OAuth Login. 5 Enforce th f
[?] UR

Force Web OAuth Reau

v on, prompts people

Use Strict Mode for Redirect URIs

Cnly at use the Facebook SDK or that exactly match the Valid OAuth Redirect URIs
Strong d. [?]

Valid OAuth Redirect URIs

| https:ffwww.domian.con'l,fadminﬁndex.php?controller:auto_poster&actién:edit&modul e=facebook&method=handleRedirect - |

Login from Devices

Once you are on the page shown on pic 4, proceed to Valid OAuth Redirect URIs configuration. You can
find Valid OAuth Redirect URIs in your Flynax-powered admin panel. Navigate to Facebook module
configuration page that can be found in the Flynax Admin Panel > Plugins > AutoPoster and click the
Edit button. It will bring up the page with configurations for the Auto Poster plugin (See pic 5). Click
the Copy button and then go back to the page shown on pic 4, paste the value in the Valid OAuth
Redirect URis field and save the changes.

The link you are pasting in the field is supposed to have the following structure: https://
v {yourdomain}/{site_adminFolder}/index.php?controller=auto_poster&action=edit&modul
e=facebook&method=handleRedirect.
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Pic 5
Admin Panel > Auto Poster > Facebook

Facebook

Module Seftings «

Copy the "“Walid OAuth
Redirect URI link

Facebook app ID * | |

Facebook app secret * | |

Post listings to * : | Facebook Group - |

Page/Group 1D

i Please fill in the field if you chose to post to

Status | Active -

Module Management -
Login with Facebook

4. Then proceed to configuring the basic settings of the App: Facebook Application Dashboard >
Settings > Basic (See pic 6).
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Pic 6

App 1D
2439065649821369

Display Name
Autoposter2
App Domains

Privacy Policy URL

App lcon (1024 x 1024)

App Purpose

* Yourself or your own business

Clients @

If you are developing an app that accesses and uses data from
Facebook's Platform on behalf of cliants, you are subject to Section Sb

of the Platform Terms.

Verification Status

Creating and setting up Facebook App

App secret
(Ll 11 ]]] Show

MNamespace

Contact Email @

some@mail.com

Terms of Service URL

Category
Choose a Category -

Find out more information about app categories here

Some permissions and features may require business or individual verification to access live data. You can start this process at any time.

Discard

You will be asked to fill in the following fields on this page:

A. App Domains. Paste the link that you had copied in the exchange buffer during the third step;

B. Privacy Policy URL. Make sure to provide a link leading to the page with Privacy Policy on your

website;

C. Term of Service URL. This field is mandatory as well as the Privacy Policy URL field;

D. Business Use. Select the option applicable to your business.

The App Icon field is not required; you may either skip it or upload an icon that will visually represent

your App.

At the bottom of the page, you will see an Add a Platform button (See pic 6), click it and select the
website platform and then enter the URL of your website in the appropriate field.

For example:

- Your Valid Oauth Uris - https://{yourdomain}/{site_adminFolder}/index.php?controller=auto_poster
&action=edit&module=facebook&method=handleRedirect

- Your domain {yourdomain}
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- Your website address https://{yourdomain}
After filling all the required fields, make sure you saved the changes.

5. Then proceed to configuring permissions of your App. Go to Facebook App Dashboard > App Review
> Permissions and Features > Add additional permissions and features (See pic 7).

Pic 7

Business Asset User !Imfm? Aﬂm

oy re— © Feady ta Lie PRegqurst Advanced Access -}

randard Actes © Raagy 12 U Request Advanced Access

You can request the Advanced Access tiough App

Review.
andand Acceny © Ready 10 Use Regoest Advanced Access -]
pages_manage_mitadita
. ? ‘Standard Access © vy ta e Fequest Advanced Access -}
pages_manage_engagemént
: Standard Aceens © Rescy 10 Use Fequest Advanced Access

The Auto Poster plugin allows for automatic posting of your ads to either your business or group page,
and each of the pages requires configuring its own permissions:

A. To post ads to your business page, you need to selecet pages_manage_posts then
Request Advanced Access.

B. To post ads to your group, you need to use groups_access_member_info and
publish_to_groups.

Then search for the three features above then Request Advanced Access for every feature. Scroll to the
top of the page and click Continue the Reugest (See pic 8).
Pic 8
Permissions and Features
W Introdusing New Data Access Lovels x
Development Mode and Live Mode have been replaced with rew daza sccrss levels, more feaibility and strearnlsne integration whven bulldeg and using your buainess app. Standard Access i3 granted automatically and permita access 10 data owned by

your business. Advaneed Aseens misst b requistid thiough App Riestim o aeerss dath dwned by peooke oulside yous business, If you domt noed any level of Bccess 1 & pemission of leslure, you eam ramave i and It will b4 [i51d a3 No Aseess
i yeu rved prrmissicns and fnatures nat listed, you can view mang by remaving your sop from the businees sop fype

i 3 m

Petmissions and Fastures 1 apicsm u 0 pecestLovel 11 @ Suts 0 Action 11 @

public_profile




o
ﬁ ﬂ.ynax Creating and setting up Facebook App

After that, go through the same steps for publish_pages and click the Continue the Request button.
The system will take you to the page for sending permissions for Facebook approval (See pic 9).

Pic 9

Request for App Review

Submit for Review In App Review Results
Approx. 6 days

You will need to complete this step in addition to App Review before you can access live data.

Business verification: You'll need to connect your app to a Facebook Business Manager account and upload an official
document showing your business or organization's name and physical address. Learn more

or

Individual Verification: You'll need to provide an emall address where you can receive, review, and submit a contract, and
uplinad an image copy of an approved 10 or document. By verifying as an individual, certain permissions or Features from your
request may not be available or will ba limited per each app installer. Learn more

Go To Verification

Submission Guidelines

Betore submitting your ragquest, read our App Review, Sample Submissions, and Comman Rejection ReASONS (0CUMEnts 1o
familiarize yourself with the process and aveid common mistakes. In addition:

Confirm that your app can be loaded and tested externally

Verify that the Facebook Login button is visible in your app and screencast, and adheres to our brand guidelines
Provide clear use case details and describe step-by-step how a person uses your app

Tell us how your use of groups_access_memhber_info follows established usage guldelines

Tell us how your use of pages_manage_posts follows established usage guidelines

Tell us how your use of publish_to_groups follows established usage guidalines

‘You must complete all steps before you can submit for review.

At this stage, you have completed basic set up of the App and you now have all the data for the Auto
Poster plugin. It is time to use this data to configure the Auto Poster plugin.
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o Configuring the Auto Poster plugin

1. The main settings (See pic 10) can be found in admin panel of your Flynax-powered site > Plugins
> Auto Poster > Facebook > Edit.

Pic 10

Admin Panel » Auto Poster > Facebook

Facebook

Module Seftings -

Copy the "Valid OAuth i i
Redirect URI" link
Facebook app ID *

Facebook app secrat *

Post listings to * Facebook Group -
Page/Group ID Please
Status . | Active -

Module Management -

The Facebook app ID, Facebook app secret, Post listings to, Page/Group ID fields are mandatory.

A. To fill in the first two fields, you will need to return to the main page of your Facebook App. From
there proceed to the Dashboard > Settings > Basic (See pic 11) and find the required App ID and App
Secret. You will need to copy the values of these fields and paste them in the appropriate fields from
the Auto Poster plugin manager.

Make sure you click the Show button on the right of the App Secret field before copying
the App Secret value.
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Pic 11

r APP ID: 2237003713018152

App ID App Secret
2237003713018152 20000909
Display Mame MNamespace

Test autoposting app

4

B. After that, you will be asked to select the option Post listings to, specifying whether your posts
will be published on your business page or group.

The last field Page/Group ID will ask you to fill in the ID of your group or business page, depending
on the option you had selected in the previous step.

v ID is a unique identifier of your business page or group made up entirely of digits.

2. After configuring all the fields and saving them, it is time to connect the Auto Poster with the
newly created Facebook App. To get started, click Login with Facebook (See pic 12).

Pic 12

Admin Panel > Auto Poster > Facebook

Facebook

Module Settings ~

Copy the "Valid OAuth :
Redirect URI" link

Facebook app ID * |

Facebook app secret*

Post listings to * Facebook Group -
Page/Group |D [ | Please
Status Active -

Module Management -
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Provided that everything has been configured correctly, you will see how long the token is valid for
above the Login with Facebook button.

With these steps configured, the Auto Poster will now send posts to either your group or business
page, whichever option you had selected previously.

3. The Plugin offers the option of Automatic post pattern, which allows you to generate dynamic
titles for your posts. To configure this option, navigate to your Flynax Admin Panel > Categories > Edit
category (See pic 13). At the very bottom of the page, you will see the option, in which you can add
both static and dynamic values. For example, by specifying a value New listings in {country} with a
price {price}, you will get values {country} and {price} changing dynamically when forming a title of
your post for your Facebook business page or group.

o Sending Facebook App for approval

After you have configured the Auto Poster App and made sure that the added listings get posted to
your business page/group on Facebook, you may proceed to sending the newly-created Facebook App
to Facebook for approval. The approval is required to make the App active and retain the required
permissions. We will walk you through the steps required for obtaining Facebook approval:

1. Go to the Facebook Application Dashboard > App Review > Current Requests and click Complete
form of the first permission (See pic 13).

Pic 13
facebook for developers

u Tail buldpedling g % APP 1Dz 223700378308152

A Dashboard

£ Sotings '

Ay Astes Requested Permissions and Features

& Aberis

@ Aew Review - Tell us how you'll use publish_pages
Curment Regus 3t 03 106 | B 11

My Prrmisiens s Fastwry

Pirakiasng 5 Fastined
Fasebook Lagin 0

T Rctivity Log
Tiell us how you'll use manage_pages

(+) Add additeonsl permisslons and foatures
Complete App Verification and Settings

Provide verification details

Yo st complele all steps before you can submit for review,
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A form will come up asking you to fill in the following fields:

A. Tell us how you're using this permission or feature - this field will ask you to describe how you
are going to use the Facebook App. Make sure to specify that you are going to use the App only for
posting ads to your own page/group. Mentioning that the page/group is owned by you will simplify
the approval procedure.

B. In the option Demonstrate how your selected platforms will use this permission or feature select
Web.

C. After selecting the Web option, you will be asked to describe in detail how your App is going to
work. Here is the approximate description of the step-by-step process in which the App works:

1. Navigate to the admin panel of the website (specify a Link);

2. Navigate to the configuration manager of the Facebook Auto Poster plugin (specify a link);
3. Configure the App by specifying Facebook App ID, Facebook and Facebook Page/Group ID;
4. Click Login with Facebook button;

5. Accept all agreements showing up in the modal window;

6. Configure an automatic pattern for posting to Facebook;

7. Navigate to the front end of your website and create a listing;

8. Check if the added listing gets posted to your Facebook page/group.

D. The next option Show us how you're using this permission or feature, will require that you record
a video from your computer screen. The video needs to show how you are going through all the
steps that you had described above. When making a screencast, make sure you explicitly show how
you are navigating to the page for configuring the module for your Facebook Auto Poster plugin,
click the Login with Facebook button, agree to permissions request in the standard modal window
Facebook Auth. Make sure the video shows how you set up automatic patterns for messages on the
category pages. The video also must show how you add a listing and the listing getting posted to your
Facebook page/group. The title of the post needs to feature a message that is generated based on the
pattern configuration.

In other words, in your video you should demonstrate that your App is going to use the very permis-
sion that you had selected. When deciding on whether to approve the App or not, the Facebook team
will pay close attention to how the titles for posts are built. It means that titles need to be generated
dynamically and controlled by you and not by the Plugin without your involvement. Lastly, you need
to explicitly demonstrate that posts gets posted to the page that you had previously specified in the
Plugin settings.

If you don’t see the modal window when clicking Login with Facebook button, navigate to
your Facebook account settings (See pic 14), highlight your App and click Remove. This will
clear the App’s cache and the next time you click Login with Facebook button, you will see
the modal window.
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Pic 14

&% General
% Security and Login

3 vour Facebook
Information

[E Privacy

=] Timeline and Tagging
Location

Q Blocking

E Language

e Notifications
Mobile
Public Posts

ﬂ Apps and Websites
(5 Instant Games

Q Business Integrations
[F3 Ads

Payments

% Support Inbox

B videos

Creating and setting up Facebook App

Apps and Websites
Logged in With Facebook

Active 6 Expired Removed

Data Access: Active

These are apps and websites you've used Facebook to log into and have rece
share with them. Learn More

Use this list to:

= View and update the info they can request
= Remove the apps and websites you no longer want

Active Apps and Websites

u..:_-. | i m |

Preferences
{:} Apps, Websites and Games i
This setting controls your ability to interact with apps, This se!
websites and games both on and off Facebook. game s
develo
Turned on. these s

Edit

Upload the video to Screencasts requirements section and click the Save button.

Repeat all the steps you had taken for the remaining second permission.

The review process normally takes 1-2 days and if you have configured and specified everything
correctly permissions will be approved and your App enabled.



